Back to overview
Downtime

Tenant City landlord zone is currently unavailable

May 19, 2026 at 10:38pm UTC
Affected services
Tenant City Portal

Resolved
May 20, 2026 at 1:43pm UTC

All services have been restored

Created
May 19, 2026 at 10:38pm UTC

The Landlord and Tenant zones of Tenant City are currently unavailable due to an issue at our hosting provider.

Engineers are working on a fix to restore services as soon as possile